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1. Precautions
1.1. Cables
Ensure that all cable connections are properly secured and that there is not excessive
strain on the cabling.
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2. System Overview
2.1. Introduction to the MotionPro Data Acquisition System

The MotionPro Data Acquisition System (MotionDAS) is a multi-function data acquisition
module for the USB 2.0 bus. The module can perform simultaneous operation of analog
input and analog output. The key hardware functions are listed below:



16 analog input channels with programmable gains.



4 analog output channels for waveform generation.



Internal or external clock source.



Trigger operations using a software command, an analog threshold value, or an
external digital input value as the trigger event.



500 V galvanic isolation barriers that prevents ground loops to maximize analog
signal integrity and protect your computer.

Analog input subsystem


16-bit A/D converter.



Throughput rate up to 500 kHz.



16 single ended analog input channels.



Programmable gain of 1, 2, 4 or 8 provides input ranges of ±10, ±5, ±2.5 and ±1.25 V.



1024-location channel-gain list. You can cycle through the channel-gain list by using
continuous scan mode or triggered scan mode. The maximum sampling rate when
using the channel-gain list is 500 kHz.

Analog output subsystem
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16-bit D/A converter.



Output rate up to 500 k samples/s.



Output range of ±10 V.
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The DACs are de-glitched to prevent noise from interfering with the output signal.



1024 location output channel list. You can cycle through the output channel list using
continuous output mode or waveform mode. For waveform generation mode, you can
simultaneously update all four DACs at 500 kHz per channel; for continuous output
mode, you can simultaneously update all four DACs at 250 kHz per channel.



External or internal clock source.



Trigger operations using a software command, an analog threshold value, or an
external digital input value as the trigger event.



A 500 V galvanic isolation barrier that prevents ground loops to maximize analog
signal integrity and protect your computer.
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2.2. System components
The MotionDAS components are listed below.


Data Acquisition System module: The MotionDAS module provides 16 analog
inputs, 4 analog outputs, and 16 digital I/O with internal or external clock source and
triggers.



Digital Interface: The USB 2.0 (480 Mb/sec) cable provides data and control signals
to and from the module. It connects the module to any USB 2.0 port on your personal
computer or laptop.



Power Source: The power supply provides external power to the device (5 V).



Data Acquisition Software and SDK: it operates in Windows 2000 or Windows XP
operating systems. It plugs into LabVIEW and MATLAB and provides an SDK for
customizable application development.

2.3. Note on operating systems
The MotionDAS is supported in the following operating systems: Windows XP (32-bit),
Windows Vista (32/64-bit), Windows 7, 8, 8.1 and 10 (32/64-bit).

8
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2.4. Software Development Kit
Upon the installation of the MotionPro DAS SDK several options are available to the user.
These options are easily accessed via the Program menu under the Windows Start
button. The programs and associated files are organized under the IDT/XsDA folder. This
folder includes the example programs and the associated documentation. The software
components included in the MotionPro DAS Software Development Kit are:


Data Acquisition stand-alone application.



SDK modules with example source code in MSVC++.



ActiveX Control.



Plug-in for LabVIEW™.



Plug-in for MATLAB™.

The SDK modules provide an API interface to develop applications to operate the device
and access all the capabilities using a programming language such as C++ and Java. A
C/C++ header file is included in the SDK (XsdaAPI.h file in the Include sub-directory).
For a more detailed description of the SDK please refer to the MotionPro DAS SDK
Reference.
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3. Installing the MotionDAS
This section specifies the minimum recommended computer requirements and gives the
procedures needed to install the device, I/O Cable, and software.

3.1. Minimum computer requirements
PC
Operating System

Windows XP, Vista, 7, 8, 8.1, 10

Processor

Pentium III or equivalent with 500 MHz processor.

RAM

2 GB

USB 2.0 Port

high speed USB port that is NOT shared with other
devices

Hard Drive

100GB or larger hard drive (recommended).

3.2. Package contents
Before beginning the installation process, check that the following items are present in the
MotionDAS package. If you are missing any of the items listed below, please contact
IDT, Inc. or your sales representative.
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Data Acquisition module.



I/O USB 2.0 Cable.



Data Acquisition Quick Start Guide.
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3.3. Software Installation
Windows XP/Vista/7/8/8.1/10
Before installing the software make sure that the computer has Windows XP or later
version installed as operating system.


Log into Windows with a username and password that has ADMINISTRATIVE
PRIVILEGES.



Download the latest MotionDAS software form IDT website.



Run the exe and follow the on-screen instructions.



Exit when the installation is complete and restart your computer.

3.4. Hardware Installation
A 5 VDC, 6 Amp supplies the device with the necessary power. This power supply unit is
included with the system package. All communication and data transfer with the host
computer is done via the USB-2 interface. This interface requires a single cable, which is
also supplied with the camera package.

Windows XP/Vista/7/8/8.1/10


Connect the device to the power source.



Connect the USB 2.0 cable to an available USB 2.0 port on your computer.



Connect the other end of the USB 2.0 cable to the device and wait a few seconds for
the device to initialize it self.



Follow the on-screen instructions. Click on the YES or Continue Anyway button
when prompted by Windows to proceed with the installation.
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3.5. Data Acquisition Back panel
Power Connector
USB 2.0 Connector

Analog Inputs Group

Analog Outputs Group

The BNC connectors are grouped in two groups:
Analog Inputs


AIN1 to AIN15: the analog input channels



Sync In: the analog input external synchronization input



Trig In: the analog input external event trigger input



Sync Out: the analog input output signal.

Analog Outputs
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AOUT1 to AOUT4: the analog output signals



Sync In: the analog output external synchronization input



Trig In: the analog output external event trigger input
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4. Data Acquisition stand-alone program
This application allows the user to acquire data from the analog inputs, save the data to
the hard disk, generate waveform for the analog output channels, open saved data files
and display the signals, apply filters and mathematical operations to the signals. Upon
execution the user can select to open a data acquisition window.

4.1. Open data acquisition device

The “Open data acquisition device” dialog box allows the user to open and configure a
data acquisition device. If more than one device is attached to the computer system, the
user may select from a list. For each device, the user may select the analog subsystems
that will be open.
Once the dialog box completes the initialization procedure for the device, the application
window for the active device is open as shown below.
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Along with the usual top bar menu structure the application also includes a docked dialog
bar on the right side and a docked dialog bar on the bottom side. In the right bar the main
operational controls of the data acquisition are grouped by function: Run control for
acquisition/waveform generation; vertical and horizontal configuration for data display;
input trigger for the configuration of the ADC trigger. The function of these controls is in
great part also accessible from the top menu bar. In the bottom bar, four buttons allow the
configuration of horizontal and vertical cursors for the computation of time, frequency and
voltage. A list shows the filter and mathematical operations applied to the signals and a
reset button allows the user to restore the original signal.

14
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4.2. Data Acquisition Menu structure
The Data Acquisition main menu contains the following options:
File
Process
Device
View
Tools
Window
Help
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4.3. FILE Menu
The file menu contains the following options:
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Open the data acquisition window.



Open a data file.



Save acquired data on the hard disk and close windows.
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4.3.1. Open a data file
Each stored data file may be open and displayed.
1. From the File menu select File > Open > Data File…
2. Select the desired folder and the file name.
3. Click Open.
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4.3.2. Save acquired data
Each acquired sequence of data may be stored on the hard disk.
1. From the File menu select File > Save Data.
2. Select the desired folder.
3. Type the file name, select the file format from the “Save as type” control.
4. Click “Save”.
The user may save data in the formats listed below:


ASCII File (TXT).



Binary File (DAT).



Tecplot File (PLT).



LabVIEW Measurement File (LVM).



Excel XML spreadsheet File (XML).

The values saved in a data file may be used as sources to generate output signals. For
further information, refer to the output channels paragraph.
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4.4. PROCESS Menu
The Process menu contains the following options:


Apply filters and remove average from the signals.



Apply mathematical operations to the signals.



Show/Hide the FFT/Power Spectrum window.

User Manual

19

MotionDAS

4.4.1. Filters and Math operations
Filter operations: low pass filter, high pass filter, Band Pass filter, Band Stop filter or
Remove average.
Mathematical operations: Negative, Invert, Square and Square Root.

The filter dialog box shows the kernel and the Frequency response of the selected filter.
The user may select the frequencies (one value for low pass and high pass filters, two
values for band pass and band stop filters), the kernel size and the windowing type
(rectangle, Bartlett, Blackman, Hamming and Hann).
If the filters or the mathematical operations are activated the operations list in the
horizontal bar is filled with those operations. The user may:
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Select the items in the list and activate the single operation.



Reset the list and delete the operations.
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4.4.2. FFT and Power Spectrum
If the “FFT” option is selected, the Fast Fourier Transform window is displayed. The user
may select the channel to display, the FFT and the power spectrum.
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4.5. DEVICE Menu
The Device Menu on the main toolbar offers an alternative to using the buttons provided
by the Docked Dialog menu including the following functions:
1. Run/Stop.
2. Single.
3. Input channels.
4. Output channels.

4.5.1. Run Control
The Run Control group at the top of the Docked Dialog menu has data acquisition control
functions including the following:

22

•

Run/Stop: start and stop continuous acquisition.

•

Single: run a single burst.
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4.5.2. Vertical controls
Use the vertical controls group in the docked vertical bar to configure the data display
vertical parameters.

Volts/div: the control sets the vertical resolution in volts/division.
Vertical displacement (Offset): the user may vertically scroll each input signal
independently. If more than one signal is displayed, select the signal from the channel list
and scroll the vertical slider.
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4.5.3. Horizontal controls
Use the horizontal controls group in the docked vertical bar to configure the data display
horizontal parameters.

ms/div: the control sets the horizontal resolution in ms/division. The option “Fit to window”
automatically sets a value that fits the signal length in the current window.
Display: scroll the blue bar to display different parts of your acquisition. The bar is
automatically resized if the length of the acquisition cannot fit in the screen.

24
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4.5.4. Input trigger
The acquisition of data is started by a trigger that can be configured by the user.

Source: the trigger source may be software (none), channel (one of the input channels
themselves) or external (edge high or edge low).
Channel: if the trigger source is channel, use this control to select it. The option is grayed
out if the source is not channel.
Level: use this option to select the trigger level value. The option is grayed out if the
source is not channel.
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4.5.5. Input channels
Use the input channels controls to configure the acquisition channels.

Channels display: the rectangle shows the open channels highlighted by a blue rectangle.
Click on the numbers to configure the channels.
Burst size: the size of the acquisition in ms.
Sync source: the synchronization source (internal or external).
Sampling rate: select the sampling rate.
Enable Sync Out: check button to enable the sync out signal. The minimum number of
input channels required to activate the sync out is 2. The sync out frequency is equal to
the Sampling rate divided by the number of input channels.

26
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4.5.6. Configuring input channels
If the input channels rectangle is clicked the dialog box below appears.

Channels button: click on the button of the channel that you want to configure.
Enable: select this option to enable/disable the channel. A disabled channel is not
sampled.
Color: select the channel display color.
Gain: select the channel gain (1X, 2X, 4X, 8X).
Default color: click this button to assign the default colors to the channels
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4.5.7. Output channels
Click the output button on the docked vertical bar and the output channels dialog box will
appear. Output parameters are independent from the input but they are activated by the
play button on the vertical toolbar.

Period: the output signal period in ms.
Sync source: the output sync source (internal or external).
Sync rate: the output rate.
Trigger source: the start trigger source may be software or external (edge high or edge
low).
Four analog output channels are available. Each channel may be independently
configured.
Current Channel: select the channel that will be configured.
Enable: select this option to enable/disable the channel. A disabled channel is not sent to
the output DAC.
Waveform: select the waveform shape (square, sine, triangle, saw tooth or File)
Amplitude - Offset - Phase: configure the waveform parameters (square, sine, triangle,
saw tooth).
File: if the waveform type is file the output channel generates a waveform read from a
WFM file. WFM files are generated and edited by the Waveform Editor. For further
information, please refer to the chapter 6.

28
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The signals are shown in the black window. The user may select the Time Base period in
µs. If the “Auto” option is selected, the application shows four waveform periods.
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4.6. View Menu
Use the View menu to activate the vertical (X1 and X2) and the horizontal (Y1 and Y2)
cursors. Use the View menu to select the toolbar options.

4.6.1. Average and Standard Deviation
The “Average/Std Dev” option in the View menu activates the “Average/Standard
Deviation” window.

For each channel the minimum, the maximum, the average and the standard deviation
values are displayed.

30

User Manual

MotionDAS

4.6.2. Cursors
You may measure waveform data using cursors. Cursors are horizontal and vertical
markers that indicate X-axis values (time) and Y-axis values (voltage) on a selected
waveform source.
The position of the cursors can be moved by dragging the triangular handles on the
screen. See the picture below.

The cursors are activated by clicking the corresponding buttons in the horizontal bottom
bar.

In the same bar the displayed values are DX (X2 – X1), the frequency and DY (Y2 – Y1).
Cursors are not always limited to the visible display. If you set a cursor, then pan and
zoom the waveform until the cursor is off-screen, its value will not be changed, and if you
pan the waveform back again it will have the cursor in its original position.
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4.7. TOOLS menu
4.7.1. Waveform Editor
1. From the Tools menu, select “Waveform Editor…”
2. The waveform editor is launched; please refer to chapter 6.

4.7.2. Options
1. From the Tools menu, select “Options…”
2. Select the colors and click OK.

32
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4.7.3. Language selection
1.

From the Tools menu, select “Language…”

2.

Select the language from the list and click OK.

4.8. WINDOW Menu
If more than a window is open in the program, use the window menu to cascade, tile
horizontally, tile vertically or select one of the windows.

4.9. HELP Menu
This menu contains support options and information including: e-mail tech support and
software and manual updates.
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5. Waveform Editor
5.1. Overview
The waveform editor is a tool for the generation of analog waveform files.
A waveform is made up of one or more components.
A component is made up of one or more primitives.
A primitive is the lowest level of a waveform. A primitive can be anything from sine
waves and triangle waves to pulses and noise. Primitives of the component are added,
subtracted, multiplied, or divided into each other.
The examples below show different waveform.

Example #1
The example below shows a waveform with one component. The component has a single
sine wave primitive.
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Example #2
The example below shows a waveform with two components. Each component is made
up of one primitive, a sine and a square wave.
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Example #3
The example below shows a waveform made up of one component. The component is
made up of 2 primitives.
The first primitive is a sine wave with the following properties:


Amplitude: 500 mV



Period: 1000 Samples



Phase: 0°

The second primitive is a sine wave with an associated operation of multiplication. This
primitive has the following properties:
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Amplitude: 5 mV



Period: 50 Samples



Phase: 0°
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5.2. The waveform editor menu structure
The Data Acquisition main menu contains the following options:
File
Edit
View
Tools
Help
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5.3. File Menu
The file menu contains the following options:


Create a new waveform.



Open a waveform file.



Save a waveform file.

5.4. Create a new waveform
Upon execution of the program the user can select to create a new waveform of open an
existing waveform file.

1. Select the “Create a new blank waveform” option and click OK.
2. Select the sampling rate and click OK.

38
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5.5. Open a waveform file
1. Upon execution of the program, select the “Open an existing waveform file” option
and click OK.
2. Browse for the waveform file to open.
3. Click the Open button.

5.6. Save a waveform
1. To save a waveform file, from the File menu, select the “Save waveform…” item.
2. Type the file name and click OK.
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5.7. Edit Menu
The edit menu contains the following options:
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Add a new component to the waveform.



Edit one of the components of the waveform.



Delete one of the components of the waveform.



Edit the waveform sampling rate.
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5.8. Add components to a waveform
1.

From the “Edit menu” select the “New Component…” item.

2.

The component editor window opens.

You may select the component name and the number of samples. The samples are
converted into ms according to the selected sampling rate.
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5.9. Insert primitives into a component

42

1.

From the component editor window select the primitive type and operation (+, -, x,
/ ).

2.

Modify the primitive parameters. Different primitive types have different
parameters.

3.

Click the “Add to List” button.

4.

You may also:


Delete a primitive from the list.



Reset the list



Move a primitive Up and Down in the list.
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5.10. Edit a component
1. From the Edit menu select the “Edit Component…” item.
2. If the waveform has a single component the edit component window will appear,
otherwise a new window will ask you to select which component to edit.
3. Select the component from the list and click OK.
4. Refer to the previous topic to add, delete and edit the primitives in the component.
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5.11. Delete a component
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1.

From the Edit menu select the “Delete component” item.

2.

If the waveform has a single component the component will be deleted, otherwise a
new window will ask you to select which component to delete.

3.

Select the component from the list and click OK.
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5.12. View Menu
Use the View menu to show or hide the main toolbar and the status bar.

5.13. Tools Menu
5.13.1.

Options

3. From the “Tools” menu, select the “Options…” item.
4. Change the background, grid, and signal colors, then click OK.

5.13.2.

Language

1. From the Tools menu, select “Language…”
2. Select the language from the list and click OK.
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5.14. Help Menu
This menu contains support options and information including: e-mail tech support and
software and manual updates.
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6. Appendix A – Product Specifications
6.1. Specifications
Analog inputs
Number of inputs

16

Resolution

16 bit

Programmable gains

1X, 2X, 4X, 8X

Ranges

±10 V, ±5 V, ±2.5 V, ±1.25 V

Single Channel A/D throughput

500 kS/s

Multi channel A/D throughput

500 kS/s ± 0.05%

A/D conversion time

2 µs

Bipolar input range

±10 V

Output coding

Offset binary

Maximum input voltage (power off)

±35 V

Maximum input voltage (power on)

±20 V

Input impedance (channel off)

100 MΩ, 10 pf

Input impedance (channel on)

100 MΩ, 100 pf

Bias current

±20 nA

Non linearity

<1/2 LSB

Analog outputs
Number of DACs

4

Resolution

16 bit

Throughput

500 kS/s

Output range

±10 V

Data coding

Offset binary

Output current

±5 mA

Output impedance

0.1 Ω

Capacitive driver capability

0.004 µF

Protection against

Short circuit to analog ground

Non linearity

1 LSB

External A/D and D/A Triggers
Internal trigger source

Software initiated

External trigger source

Software selected

Input type

Edge sensitive

Logic

TTL

Input termination

2.2 kΩ pull-up to +3.3 V

Logic high input voltage

2.0 V

Logic low input voltage

0.8 V
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Minimum pulse width

25 ns

Miscellaneous
Interface

USB 2.0

Operating systems

Windows 2000/XP

Plug’ n ‘play

Yes

Power requirements

5 V DC at 2 A maximum

Operating temperature range

0 º to +55º C

Relative humidity

95%
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